Introducing Peach MyBB Theme - Absolute Delight Check details here
My SQL Error
#1
Hello. I have purchased Focus Responsive as a theme for my forum. I am trying to install the recent threads plugin that was specifically specified to be used in the comments of the tutorial. After uploading the files to my root directory, I tried to install and active the plugin and I get a MySQL error: "SQL Error: 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'rows FROM mybbqc_settinggroups' at line 1 Query: SELECT COUNT(*) as rows FROM mybbqc_settinggroups."

This prevents me from accessing my forums admin cp until I have to re-open the entire admin cp. I don't know if this is a compatibility issue or if the plugin suggested is no longer something I need to use. I have tried using other recent thread plugins, but I cannot figure out how to get them to show up where it needs to.

I'm using the latest firefox browser. I'm using a windows 10 PC. MyBB Version 1.8.22, PHP Version 7.2.31, SQL Engine MySQLi 10.3.23.

I have also reported the issue on mybb community forum because I'm not sure what kind of issue this is just yet. Is there any way for me to use a different recent thread plugin and still get the desired results?
Reply
#2
Hey candlejacked,
This is probably because the plugin might be bugged now. Try this plugin by dragonexpert which has been updated recently
https://community.mybb.com/mods.php?action=view&pid=191

Regards
WallBB
Reply
#3
Thank you for your reply. Sorry that I had to repost in two separate areas. I am occasionally running into a MySQL error when trying to access this forum: ""SQL Error: 1040 - Too many connections Query: [READ] Unable to connect to MySQL server." I've encountered this problem twice today where I have been unable to access it for a short while. I am unsure if it's an error on my side or not.

The skin is beautiful and I am happy with it. However, I am still having trouble with getting the recent threads to work as intended. I am unsure if it's because I am not doing something correctly or if I had to make a tweak somewhere in the theme to make it work. I have been using the dev's thread as a reference, trying a number of suggestions. I am trying to weed out what the problem might be so that I can narrow down the issue and find the correct fix from the correct person.

I have checked the permissions for the plugin to make sure that everyone, including me, can see the recent threads.

Index template to show that I have included the variables:
Code:
<html>
<head>
<title>{$mybb->settings['bbname']}</title>
    {$headerinclude}{$recentthread_headerinclude}    
<script type="text/javascript">
<!--
    lang.no_new_posts = "{$lang->no_new_posts}";
    lang.click_mark_read = "{$lang->click_mark_read}";
// -->
</script>
</head>
<body>
{$header}
<div class="forum">
{$forums}
</div>
<div class="sidebar"><br/>
    <table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
        <tr>
            <td class="thead">
                <strong><i class="fa fa-comments"></i> Recent Posts</strong>
            </td>
        </tr>
        <tr>
            <td class="trow1">
                <div id="recentthreads">{$recentthreadtable}</div>
            </td>
        </tr>
    </table>
    <br/>
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead"><strong><i class="fas fa-chart-pie"></i> Forum Stats</strong></td>
</tr>
<tr>
<td class="trow1">
<span class="smalltext">
{$mybb->settings['bbname']} has {$stats['numusers']} members<br />
Our Newest Member is {$newestmember}<br />
We have total number of Threads : {$stats['numthreads']}<br />
We have total number of Posts : {$stats['numposts']}
</span>
</td>
</tr>
</table>
<br />
<table border="0" cellspacing="{$theme['borderwidth']}" cellpadding="{$theme['tablespace']}" class="tborder">
<tr>
<td class="thead">
<strong><i class="fas fa-registered"></i> Advertise here</strong>
</td>
</tr>
<tr>
<td class="trow1">
Please use contact us to advertise here, dimensions 250px X 250px<br/>
</td>
</tr>
</table><br/>
</div>
{$boardstats}
<br class="clear" />
{$footer}
</body>
</html>

I am hoping that I haven't removed something in the index template when originally following the instructions to install the previous plugin. Thank you for your time.


Attached Files Thumbnail(s)
   
Reply
#4
Can I fix this for you?
Will it be possible that you can share a temporay admin login via PM ?
Reply
#5
Absolutely. I will PM you details.
Reply
#6
I have sent you a PM, I found that the template for the plugin are not created and it is probably because all the plugin files are not uploaded.
Make sure to upload all files, uninstall and install again.

Regards
WallBB
Reply
#7
I figured out that the plugin listed on the mybb extensions page (the one that you linked) is not up to date and were missing the template files needed to make the plugin function properly. I have downloaded and installed the version listed on the Github and it works. I just have to format it to my liking.

Thank you for your help and sorry that I wasted your time.
Reply
#8
(06-26-2020, 03:43 AM)candlejacked Wrote: I figured out that the plugin listed on the mybb extensions page (the one that you linked) is not up to date and were missing the template files needed to make the plugin function properly. I have downloaded and installed the version listed on the Github and it works. I just have to format it to my liking.

Thank you for your help and sorry that I wasted your time.
No problem candlejacked Smile
I am happy that it worked and good luck with your forums.

Regards
WallBB
Reply




Users browsing this thread: 1 Guest(s)